FIXED: High GPU demand

Hey, I’m getting high gpu/cpu temperatures only from this program, like extra 10-15 degrees is there a way to reduce it? Even Ableton uses 3x less resources. I’m already using cooling pad, is there a low spec mode or something?
My laptop Dell inspiron 13 7000 2 in 1
16gb RAM
i7-10510U
Intel® UHD Graphics 620
512GB M.2 PCIe NVMe

You can reduce the GPU load by turning off ‘Glow’ in the Settings. This is the only thing to tweak really though. Ableton doesn’t really use the GPU so it’s a different beast. OSC/PILOT is heavy on the GPU to make it look the way it does (especially at high resolutions).

Would love some more options to tweak there for VJ use

Hi, same issue here… GPU at 99+ % all of the time. That will stop me buying this product, although i’dd really love it… Specs:
Dell Latitude 5289
8gb RAM
i5 7300U - quad core
Intel® UHD Graphics 620
256GB SATA
Turning off Glow in the settings does not have any reducing effect…

Hope this will be resolved in some way.

Thanks,
Danny

1 Like

Thanks, I’ll take a closer look. Maybe it’s trying to redraw at a very high FPS on systems that arn’t vsynced or something. I have a lower power Intel GPU here I can test with and see what I come up with.

Thanks Malcom, thats great!
Some extra information: i installed it on a workstation with a Geforce RTX 2080 and it was consuming 25% on avarage… I think that is a big chunck of the total capacity of the card. Sadly i don’t have a touch screen on that machine but i might consider buying one :grinning:

Same issue here. OSC Pilot uses at least 90-99% of the GPU without even being used, even when it’s minimized to the background on a Ryzen 3 Pro 3200GE with Radeon Vega 8 GPU. I can usually run most games in at least 720p on this machine. Would be great to get this fixed because I’ve had to resort to a physical midi controller for now to prevent my machine from burning out.

Any progress on this Malcom?

Malcom I ran MSI overlay when running OSC Pilot. The FPS of my monitor jumps from 24 FPS when running normal windows programs to 150-400 FPS when running OSC pilot. If you can give an option to restrict the FPS to say 60 or 30 FPS this should give a temporary fix.

Do you have VSync turned off? It should at the very least be limited to your monitor refresh if you have vsync on. This is on my next item todo though.

I don’t have a vsync option on the Dell Latitude 5289. When going through the grafics settings, id did see the scale was set to 125%. Changed that to 100% but i has a minimal effect. Probably it’s not related…

I’ve posted a new pre-release build that will hopefully fix this:


Let me know how it works for you and thanks for your reports.

Thank you Malcolm,
No need for cooling pad, from 75-85 degrees with extra cooling to ~50 degrees,
GPU from 95%-100% to 20%-30% on INTEL HD 620 great work!

Legend, thanks Malcolm!

I will try this as soon as I get back to the Ryzen machine which had the issue with.

Fyi, I ran the same MSI overlay on my Nvidia Quadro machine with the old OSCpilot version and it runs at 30fps constantly and only 5% usage, so it may have been an issue with non-Nvidia or dedicated GPUs with less optimization.

Look forward to trying the pre-release. I will let you know the outcome.