FIXED: Copy paste Zeros/Copy paste widget position

OS: Mac
Version: 1.5.4
This happens when i try to paste (17)
And when I try to paste multiple widgets, some of them goes to back.

Hey, can you elaborate? I’m not sure I follow what you mean by ‘goes to black’? I see you’ve pasted a widget here and it appears ontop of the existing one, but then you move it off using the arrow keys.

I moved so 0’s could be seen(when i duplicate buttons widget i get some corrupted 0’s), and for widget that goes to back, well… Try to put some text on the widget, send that widget to the back and bring text to the front, then try to copy all of it, when you duplicate some of the text will be send to back.

I found the problem, Buttons widget adds 0 if text field is blank, so every time you restart oscp it looks for blank spaces and replaces them to 0

Hey, I’ve tried a bunch and I’m unable to reproduce this. Can you share your .plt file that exhibits this behaviour? You can PM it to me if you want. Thanks and sorry about this bug.

Sure, could it be that plt file got corrupted when you fixed my previous mistake with the symbol?

Looks like just a bug with Buttons widgets. It was loading the TEXT value incorrectly, nothing specific to your file. This will be fixed in builds 1.5.5 and later.
Still not sure about the issue you are mentioning about pasting the widgets though, I don’t see quite what is occurring wrong in the gif. Can you explain that more?

Sure thing Malcolm, if you paste multiple widgets on the widget some of the copied widgets loose their position check layer 2.

Thanks for the report. This will be fixed in build 1.5.5 and later.

Pre-Release build v1.6.1 is now available here: