FIXED: Certain switches not responding to touch

Hey hey hey!

Firstly, let me say that I love this application, it’s definitely the best that I’ve found on the market. My intention is to use it to control VCV Rack to circumvent purchasing super expensive hardware. So now, onto my problem…

So, I’ve tested some faders and buttons and things with VCV rack and everything is great except for this button page I’m trying to use to control a switching matrix. I added a 16x16 button matrix that fills one workspace, but for some reason, a large number of the buttons don’t respond at all. It seems like mostly only the buttons in the center work as expected, and many others are either INCREDIBLY unreliable to activate upon touch or won’t respond at all. Thinking it may have been my Surface Pro 3 digitizer, I tried rotating to portrait orientation to move which part of the screen the unresponsive buttons are located on, but nothing changed; the buttons that worked before continued working and the ones that didn’t showed no change, even though they were now located in a screen area where the functional buttons were while in landscape.

Using OSC/Pilot to control this switching matrix is integral to how I intended to use the application and it’s rather disappointing to find it inoperable. Help would be immensely appreciated!


Quick update, this may be a bug. This only happens when the buttons are set as circles. When they’re rectangular, everything works perfectly. :man_shrugging:t2:

Thanks so much for reporting this! I’ll get this fixed for the next build. Sorry you ran into this bug

This bug is now fixed. Pre-Release build is available here:

1 Like