OSC companion app not reflecting UI from desktop

I’ve got OSC’s companion app communicating with the desktop application which is controlling parameters in my DAW. When I change parameters in my DAW it is reflected in the UI of the desktop app, however it is not updating the UI on the companion app which remains static at the last setting I’ve changed in the UI. Is it possible to get that feedback to the companion app’s UI like in the Desktop app?


They should work the same, unless there is something blocking the UDP packets going back to the companion app.
Are you running both at the same time, and maybe the DAW is only sending to one?

Hi Malcolm,
Thanks for the reply. I’ve was running them both at the same time (App on PC and companion app on ipad) and the DAW receives from both fine, however only the desktop app (on the same pc as the DAW) gets feedback to the UI. I’ve also tried with my laptop running the desktop app and have the same issue. I’ve also tried running them one at a time and have the same issue, only the desktop app on the same computer receives feedback, while the remote desktop app on laptop and companion app on ipad are able to send commands, however they are not receiving feedback. I’ve tried making a rule on the firewall to allow my pc to send to the allocated port number, though that hasn’t made any difference. I’m not sure what else would be blocking the UDP packets going back to the remote apps.

Hey, it’s hard to say. Do you know any other tools like TouchDesigner where you could send test OSC messages to the iPad to see if those are received?

I have TouchDesigner installed, but have no real experience with the program. I’ve tried sending messages through outosc1 after watching a short tutorial, though I may have things set up incorrectly and haven’t been able to receive the test osc messages yet. If you are able to point me in the right direction to some resources on how to set this up I’d be grateful for the advice, I’ll continue to look into it when I have time. Thanks for your help so far, I appreciate it.

Hi Malcom,
My problem’s been resolved. Turns out it wasn’t all that complexed, just me being inexperienced.

I reached out to the developer of ReaLearn (which is the plugin that I’m using to extend the MIDI Learn capabilities of Reaper), and his message said; “Thanks for reaching out. The first thing I would check is if the “Device host” and “Device port” are correct. The “Device host” needs to be set to the IP address of the iPad or other Laptop. The “Device port” needs to be set to the port number that’s configured in OSC/Pilot. Are you sure you got that correct?”

Following this advice solved the issue and now it’s working as I hoped it would. Thanks Malcom