Fullscreen is unpredictable

Hello. I was doing a video install at an event and had some unreliable functionality from Pilot. We had a projector, a standard monitor, and a touch screen for OSCP. Sometimes when I used the fullscreen button in OSCP, the window would fly off into no man’s land. Other times it would fly onto the standard display. I experimented with some different variables, including setting the “Main display” to different monitors, but it never seemed to act reliably. I was able to get it set each time after playing around a bit, but If there are any hiccups during the show, I wont be able to go fullscreen with it after troubleshooting. Any tips or similar experiences?

Resolume Arena 7
Madmapper 5

Sorry this issue is happening. Did the monitors you are using have any scaling applied to them? Can you give me an idea of your monitor layout and the resolutions of each monitor so I can try to reproduce? Thanks

Hi Malcolm, Thanks for the reply. The two monitors were both 1920 x 1080, and the projector was 4K. No scaling on any monitor, and EDIDs were set
One of the 1080’s was the touch screen we wanted OSC to be on. There was a lot of finagling needed with the “Make this my main display” checkbox in Windows (10) display options.

Ok, the way I have it intended to work it that it’ll go fullscreen on whatever monitor the window is on when you hit the fullscreen button. I’ll take a look and see if I can reproduce this issue.

Thanks for your time!

Can you say (or post a screenshot) of the monitor configuration so I can more accurately reproduce your case? Things are working with my testing so far. Where each one is laid out next to each other etc.

1080touch | 1080

I’ve attached a picture of the exhibit.
I had OSCP, resolume and madmapper running. madmapper sending Fullscreen to the 4k, and resolume sending Fullscreen to the right side. I had to juggle around those apps and their outputs, as well as OSCP each time I went to go live

Ah thanks, I meant on the windows desktop, did you have it the same way, with the 4k monitor above the other two?

I just noticed the forum rejected my previous response for being too short.
Yes, I laid it out in the display properties to match the above