Can't get Mac OS App to connect to iPad App

Mac OS 11.7.6
iPad OS 15.8.2
iPad model iPad Air 2

In the app settings/file for host I’ve tried and my home IP address.
For ports I’ve tried 1123, 8001, 8000.
Whenever I change the host or port in the app it freezes and I have to restart it.
Then my entered values are still there, but when I click update I’m still stuck with the default project.

What am I doing wrong?

It’s a shame that this critical step is not documented anywhere…

So am I correct that the task you are trying to do is connect the iPad app to OSC/PILOT running on your desktop, so you can do the remote update of the file?

The IP address you should use is the one for your desktop. You can get that in the System Settings->Network section of your macOS. The IP is generally something that starts with 192.168.
Then make sure you select ‘Enable Server’ on the macOS. The port you should use is the one listed there.

The alternative is to just save your .plt project file to your iCloud, and then open the files from there on your iPad.

Let me know if that helps or what your next questions are

I don’t see what you’re talking about.
When I open system preferences/network then I see my Wi-Fi network listed there.
If I click on advanced for the Wi-Fi and then go to the tab TCP/IP then I see a IPv4 address, a subnet mask and my routers IP.
There’s no option for “Enable Server” or anything about ports.

Sorry, the Enable Server part is in the OSC/PILOT settings. So after you get your IP address from the WIFI settings in the OS, then you go to the OSC/PILOT settings and enter that (on the iPad)

Ok, that worked. Thank you