Connecting OSC Pilot to a seperate device


I am trying to connect OSC Pilot on one device - to Resolume on a second device! How do I go about doing this ? I think I have tried every combination but I can’t work it out!

My Device running Resolume is displaying an IP address of 169.255? I believe this could be the issue? Does anyone know anything about this?

Many Thanks!

An IP address has 4 groups of digits, for example. So you should have something like that to fill in the Address field


So I was having problems linking one device to another because of Windows Defender - The firewall was blocking my IP address was connecting to a 192. number so we had to first disable the firewall on both devices to allow open communcation - then we had to give permission to Windows Firewall to allow the applications to openly commincate over the network. The 169.255 number meant that my laptop was not correctly communicating with the DCHP meaning that the devices could not communicate through the network.

Then we had to manually open the ports 7000 and 7001 to allow for the OSC address to be sent back and forth. We only we are able to get OSCPilot to Resolume working, and not the other way around. So I can use OSCPilot to control Resolume, but anything the other way round will not be updated in OSCPilot - meaning that the parameters inside OSCpIlot display incorrectly to the true value. Still not sure as to why this is, but any furthur progress I will post in here!

Hope this helps anyone who ecounters the same issue

I’d try out different ports to see if those work. It’s possible the port is already in use